Open Closed

500 Internal Server Error While publishing site #1967


0
Shoba24 created
  • ABP Framework version: v4.4.2
  • UI type: MVC
  • DB provider: EF Core
  • Tiered (MVC) or Identity Server Separated (Angular): yes
  • Exception message and stack trace:
  • Steps to reproduce the issue:"

Hi ,

This is our code to redirect web page to dashboard.This is working fine in local.But we get internal server error when site gets published.


12 Answer(s)
  • 0
    cotur created
    Support Team

    Hi @Shoba24,

    Can you please share some logs from production?

  • 0
    Shoba24 created

    can u share ur mail to share logs?

  • 0
    gterdem created
    Support Team

    Paste the log lines related with error to this post please.

  • 0
    Shoba24 created

    2021-10-11 11:18:53.860 +00:00 [INF] Request starting HTTP/1.1 GET http://cozywebqa.azurewebsites.net/ - - 2021-10-11 11:18:53.867 +00:00 [INF] Executing endpoint '/Index' 2021-10-11 11:18:53.870 +00:00 [INF] Route matched with {page = "/Index", action = "", controller = "", area = ""}. Executing page /Index 2021-10-11 11:18:53.871 +00:00 [INF] Skipping the execution of current filter as its not the most effective filter implementing the policy Microsoft.AspNetCore.Mvc.ViewFeatures.IAntiforgeryPolicy 2021-10-11 11:18:53.877 +00:00 [INF] Executing handler method GenieERP.Web.Pages.IndexModel.OnGet - ModelState is "Valid" 2021-10-11 11:18:53.878 +00:00 [INF] AuthenticationScheme: oidc was challenged. 2021-10-11 11:18:53.878 +00:00 [INF] Executed handler method OnGet, returned result . 2021-10-11 11:18:53.878 +00:00 [INF] Executing an implicit handler method - ModelState is "Valid" 2021-10-11 11:18:53.878 +00:00 [INF] Executed an implicit handler method, returned result Microsoft.AspNetCore.Mvc.RazorPages.PageResult. 2021-10-11 11:18:53.966 +00:00 [INF] Authorization failed. These requirements were not met: PermissionRequirement: SettingManagement.Emailing 2021-10-11 11:18:53.966 +00:00 [INF] Authorization failed. These requirements were not met: PermissionRequirement: AbpAccount.SettingManagement 2021-10-11 11:18:53.966 +00:00 [INF] Authorization failed. These requirements were not met: PermissionRequirement: AbpIdentity.SettingManagement 2021-10-11 11:18:53.966 +00:00 [INF] Authorization failed. These requirements were not met: PermissionRequirement: LeptonThemeManagement.Settings 2021-10-11 11:18:53.966 +00:00 [INF] Authorization failed. These requirements were not met: PermissionRequirement: CmsKit.SettingManagement 2021-10-11 11:18:53.992 +00:00 [INF] Authorization failed. These requirements were not met: PermissionRequirement: Forms.Form 2021-10-11 11:18:54.028 +00:00 [INF] Executed page /Index in 158.33ms 2021-10-11 11:18:54.028 +00:00 [INF] Executed endpoint '/Index' 2021-10-11 11:18:54.029 +00:00 [INF] Request finished HTTP/1.1 GET http://cozywebqa.azurewebsites.net/ - - - 302 - text/html;+charset=utf-8 169.3132ms

  • 0
    gterdem created
    Support Team

    These are information logs about lack of permissions.

    Can you search for [ERR] and share related errors?

  • 0
    Shoba24 created

    Reproducing steps .

    1. Open Web site. shows 500 with go back home option.

    2. Click Go back home. redirects to Login page

    3. Login now all claims are displaying in ID server home page

    4. Change the url directly in id to web in browser. Able to see the dashboard

    The issue is in redirection,

  • 0
    Shoba24 created

    Hi gterdem ,

    Any update?

  • 0
    albert created
    Support Team

    did you configure your Identity Server? Eg:

    • RootUrl in appsettings.json
    • database tables: IdentityServerClientPostLogoutRedirectUris, IdentityServerClientRedirectUris or any other tables

    replace all localhost addresses in your settings!

  • 0
    Shoba24 created

    Both r correct

  • 0
    gterdem created
    Support Team

    It is not possible to understand the error without checking the logs.

    Please reproduce the error and then check the logs (Log/logs.txt or console output) and search for [ERR].

  • 0
    Shoba24 created

    There is no error.It shows 302 code ,issue with redirection only.

    2021-10-11 11:18:54.029 +00:00 [INF] Request finished HTTP/1.1 GET http://cozywebqa.azurewebsites.net/ - - - 302 - text/html;+charset=utf-8 169.3132ms

  • 0
    albert created
    Support Team

    this is related to Identity Server configuration.