Open Closed

Volo.Abp packages NetStandard & Net 5 inconsistency problem? #2013


0
selinkoykiran created

Hello, We have still netstandard2.0 targeted framework projects in our team .In one of our project we want to use Volo.Abp.AspNetCore 4.3.3 package and we've realized the dependency like below :

so we couldn't use the package. That's not a problem actually , we need to change target framework to .net 5 .That's ok from our side. BUT for example Volo.Abp.AspNetCore.Mvc.Contracts package still can work with .net standard like below :

So do you think is there any incosistency between these volo packages ? Why some of them support .net 5 and above and some of them still in .net standard ?

Thank you.

  • ABP Framework version: v4.3.3
  • UI type: MVC
  • DB provider: EF Core
  • Tiered (MVC) or Identity Server Separated (Angular): yes / no
  • Exception message and stack trace:
  • Steps to reproduce the issue:"

4 Answer(s)
  • 0
    maliming created
    Support Team

    hi

    We will use netstandard as the target framework of the package as much as possible, but some services of net6 used in Volo.Abp.AspNetCore cannot use netstandard. Contracts package does not have this case.

  • 0
    selinkoykiran created

    Hello , Is there any spesific reason to choose netstandard as target framework ? If we change all layers to .net5 , will we run into an unexpected error ?

    Thank you.

  • 0
    maliming created
    Support Team

    NET Standard as the target platform's class library will be able to run on all .NET platforms

    If we change all layers to .net5 , will we run into an unexpected error ?

    No. Your application will be fine.

  • 0
    enisn created
    Support Team

    Shared libraries especially not related with AspNetCore are targetting netstandard. Because they can be used from any platform such as dektop, mobile, IOT runtime and even more.

    Those packages will work fine in your .net 5 runtime and any other .net runtimes.