Open Closed

abp Jquery version #2163


0
[email protected] created

I am trying to adapt metronic8 template to abp. That's why I waited for abp 5.0. for bootstrap 5. I see that you are using version 3.3.1 of jquery in abp 5.0 as well. Why don't you switch to jquery 3.6.0

PS: jquery 3.3.1 causes a lot of conflicts, in metronic8.

That's why I wanted to ask.


4 Answer(s)
  • 0
    EngincanV created
    Support Team

    Hi @[email protected], if you need to update the jquery version to 3.6.0, you can add a resolutions section to your package.json file and specify the version of the package you want. Then run the yarn install && gulp command on your terminal.

    For more info about resolutions system of yarn, see here

    {
        "name": "Acme.BookStore",
        "dependencies": {
          //...
        }
        "resolutions": {
            "jQuery": "3.6.0",
        }
    }
    
    
  • 0
    berkansasmaz created
    Support Team

    Then run the yarn install && gulp command on your terminal.

    A small fix:

    Since gulpfile has been removed from abp v5.0.* templates, you will get an error when you do yarn install && gulp with it. However, you can do the same with the following command, FYI.

    abp install-libs

    References:

    • https://blog.abp.io/abp/ABP-IO-Platform-5.0-RC-1-Has-Been-Released
  • 0
    [email protected] created

    Teşekkürler arkadaşlar. deneyip haber vereceğim.

  • 0
    EngincanV created
    Support Team

    Hi @[email protected], did you try it?