Open Closed

Angular: ABP setting-management #236


0
vishalnikam created

Check the docs before asking a question: https://docs.abp.io/en/commercial/latest/ Check the samples, to see the basic tasks: https://docs.abp.io/en/commercial/latest/samples/index The exact solution to your question may have been answered before, please use the search on the homepage.

  • ABP Framework version: v2.7.0
  • UI type: Angular
  • Tiered (MVC) or Identity Server Seperated (Angular): yes
  • Exception message and stack trace:
  • Steps to reproduce the issue:

http://localhost:4200/setting-management

Setting managemnt page is not getting dispalyed. No error and no backend api (/api/identity/settings) hit Error and warning on yarn start


11 Answer(s)
  • 0
    alper created
    Support Team

    do you see any browser console log?

  • 0
    vishalnikam created

    here is console log. there is noting in Network tab

  • 0
    Mehmet created
    Support Team

    The compiling error and these warnings are not a problem for your application. Can you upgrade the ABP version to v2.9? The problem may be resolved.

  • 0
    vishalnikam created

    i cant update ABP version at this point of time. I deleted node_modules folder and yarn.lock from angular app . Tried to fresh build and dependency for the angualr app. found below issues. Could you please help to sort out

    ERROR in ./node_modules/@volo/abp.ng.identity.config/ivy_ngcc/fesm2015/volo-abp.ng.identity.config.js 656:39-67
    "export 'OrganizationMembersComponent' was not found in '@volo/abp.ng.identity' ERROR in ./node_modules/@volo/abp.ng.identity.config/ivy_ngcc/fesm2015/volo-abp.ng.identity.config.js 709:39-65
    "export 'OrganizationRolesComponent' was not found in '@volo/abp.ng.identity'

    ERROR in node_modules/@volo/abp.ng.identity.config/lib/tokens/extensions.token.d.ts:2:41 - error TS2305: Module '"../../../../../../../../../Projects/core-platform/SCV.Litmus/angular/node_modules/@volo/abp.ng.identity/volo-abp.ng.identity"' has no exported member 'OrganizationUnitWithDetailsDto'.
    
    2 import { eIdentityComponents, Identity, OrganizationUnitWithDetailsDto } from '@volo/abp.ng.identity';
                                              ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
    node_modules/@volo/abp.ng.identity.config/lib/tokens/extensions.token.d.ts:7:5 - error TS1170: A computed property name in a type literal must refer to an expression whose type is a literal type or a 'unique symbol' type.
    
    7     [eIdentityComponents.OrganizationMembers]: import("@volo/abp.commercial.ng.ui").EntityAction<Identity.UserItem>[];
          ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
    node_modules/@volo/abp.ng.identity.config/lib/tokens/extensions.token.d.ts:7:26 - error TS2339: Property 'OrganizationMembers' does not exist on type 'typeof eIdentityComponents'.
    
    7     [eIdentityComponents.OrganizationMembers]: import("@volo/abp.commercial.ng.ui").EntityAction<Identity.UserItem>[];
                               ~~~~~~~~~~~~~~~~~~~
    node_modules/@volo/abp.ng.identity.config/lib/tokens/extensions.token.d.ts:8:5 - error TS1170: A computed property name in a type literal must refer to an expression whose type is a literal type or a 'unique symbol' type.
    
    8     [eIdentityComponents.OrganizationRoles]: import("@volo/abp.commercial.ng.ui").EntityAction<Identity.RoleItem>[];
          ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
    node_modules/@volo/abp.ng.identity.config/lib/tokens/extensions.token.d.ts:8:26 - error TS2339: Property 'OrganizationRoles' does not exist on type 'typeof eIdentityComponents'.
    
    8     [eIdentityComponents.OrganizationRoles]: import("@volo/abp.commercial.ng.ui").EntityAction<Identity.RoleItem>[];
                               ~~~~~~~~~~~~~~~~~
    node_modules/@volo/abp.ng.identity.config/lib/tokens/extensions.token.d.ts:14:5 - error TS1170: A computed property name in a type literal must refer to an expression whose type is a literal type or a 'unique symbol' type.        
    
    14     [eIdentityComponents.OrganizationUnits]: import("@volo/abp.commercial.ng.ui").ToolbarAction<OrganizationUnitWithDetailsDto[]>[];
           ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
    node_modules/@volo/abp.ng.identity.config/lib/tokens/extensions.token.d.ts:14:26 - error TS2339: Property 'OrganizationUnits' does not exist on type 'typeof eIdentityComponents'.
    
    14     [eIdentityComponents.OrganizationUnits]: import("@volo/abp.commercial.ng.ui").ToolbarAction<OrganizationUnitWithDetailsDto[]>[];
                                ~~~~~~~~~~~~~~~~~
    node_modules/@volo/abp.ng.identity.config/lib/tokens/extensions.token.d.ts:20:5 - error TS1170: A computed property name in a type literal must refer to an expression whose type is a literal type or a 'unique symbol' type.        
    
    20     [eIdentityComponents.OrganizationMembers]: import("@volo/abp.commercial.ng.ui").EntityProp<Identity.UserItem>[];
           ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
    node_modules/@volo/abp.ng.identity.config/lib/tokens/extensions.token.d.ts:20:26 - error TS2339: Property 'OrganizationMembers' does not exist on type 'typeof eIdentityComponents'.
    
    20     [eIdentityComponents.OrganizationMembers]: import("@volo/abp.commercial.ng.ui").EntityProp<Identity.UserItem>[];
                                ~~~~~~~~~~~~~~~~~~~
    node_modules/@volo/abp.ng.identity.config/lib/tokens/extensions.token.d.ts:21:5 - error TS1170: A computed property name in a type literal must refer to an expression whose type is a literal type or a 'unique symbol' type.        
    
    21     [eIdentityComponents.OrganizationRoles]: import("@volo/abp.commercial.ng.ui").EntityProp<Identity.RoleItem>[];
           ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
    node_modules/@volo/abp.ng.identity.config/lib/tokens/extensions.token.d.ts:21:26 - error TS2339: Property 'OrganizationRoles' does not exist on type 'typeof eIdentityComponents'.
    
    21     [eIdentityComponents.OrganizationRoles]: import("@volo/abp.commercial.ng.ui").EntityProp<Identity.RoleItem>[];
                                ~~~~~~~~~~~~~~~~~
    node_modules/@volo/abp.ng.identity.config/lib/tokens/extensions.token.d.ts:37:5 - error TS1170: A computed property name in a type literal must refer to an expression whose type is a literal type or a 'unique symbol' type.        
    
    37     [eIdentityComponents.OrganizationMembers]: import("@volo/abp.commercial.ng.ui/lib/models/actions").ActionContributorCallback<import("@volo/abp.commercial.ng.ui").EntityActionList<Identity.UserItem>>[];
           ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
    node_modules/@volo/abp.ng.identity.config/lib/tokens/extensions.token.d.ts:37:26 - error TS2339: Property 'OrganizationMembers' does not exist on type 'typeof eIdentityComponents'.
    
    37     [eIdentityComponents.OrganizationMembers]: import("@volo/abp.commercial.ng.ui/lib/models/actions").ActionContributorCallback<import("@volo/abp.commercial.ng.ui").EntityActionList<Identity.UserItem>>[];
                                ~~~~~~~~~~~~~~~~~~~
    node_modules/@volo/abp.ng.identity.config/lib/tokens/extensions.token.d.ts:38:5 - error TS1170: A computed property name in a type literal must refer to an expression whose type is a literal type or a 'unique symbol' type.        
    
    38     [eIdentityComponents.OrganizationRoles]: import("@volo/abp.commercial.ng.ui/lib/models/actions").ActionContributorCallback<import("@volo/abp.commercial.ng.ui").EntityActionList<Identity.RoleItem>>[];
           ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
    node_modules/@volo/abp.ng.identity.config/lib/tokens/extensions.token.d.ts:38:26 - error TS2339: Property 'OrganizationRoles' does not exist on type 'typeof eIdentityComponents'.
    
    38     [eIdentityComponents.OrganizationRoles]: import("@volo/abp.commercial.ng.ui/lib/models/actions").ActionContributorCallback<import("@volo/abp.commercial.ng.ui").EntityActionList<Identity.RoleItem>>[];
                                ~~~~~~~~~~~~~~~~~
    node_modules/@volo/abp.ng.identity.config/lib/tokens/extensions.token.d.ts:44:5 - error TS1170: A computed property name in a type literal must refer to an expression whose type is a literal type or a 'unique symbol' type.        
    
    44     [eIdentityComponents.OrganizationUnits]: import("@volo/abp.commercial.ng.ui/lib/models/actions").ActionContributorCallback<import("@volo/abp.commercial.ng.ui").ToolbarActionList<OrganizationUnitWithDetailsDto[]>>[];        
           ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
    node_modules/@volo/abp.ng.identity.config/lib/tokens/extensions.token.d.ts:44:26 - error TS2339: Property 'OrganizationUnits' does not exist on type 'typeof eIdentityComponents'.
    
    44     [eIdentityComponents.OrganizationUnits]: import("@volo/abp.commercial.ng.ui/lib/models/actions").ActionContributorCallback<import("@volo/abp.commercial.ng.ui").ToolbarActionList<OrganizationUnitWithDetailsDto[]>>[];        
                                ~~~~~~~~~~~~~~~~~
    node_modules/@volo/abp.ng.identity.config/lib/tokens/extensions.token.d.ts:50:5 - error TS1170: A computed property name in a type literal must refer to an expression whose type is a literal type or a 'unique symbol' type.        
    
    50     [eIdentityComponents.OrganizationMembers]: import("@volo/abp.commercial.ng.ui/lib/models/props").PropContributorCallback<import("@volo/abp.commercial.ng.ui").EntityPropList<Identity.UserItem>>[];
           ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
    node_modules/@volo/abp.ng.identity.config/lib/tokens/extensions.token.d.ts:50:26 - error TS2339: Property 'OrganizationMembers' does not exist on type 'typeof eIdentityComponents'.
    
    50     [eIdentityComponents.OrganizationMembers]: import("@volo/abp.commercial.ng.ui/lib/models/props").PropContributorCallback<import("@volo/abp.commercial.ng.ui").EntityPropList<Identity.UserItem>>[];
                                ~~~~~~~~~~~~~~~~~~~
    node_modules/@volo/abp.ng.identity.config/lib/tokens/extensions.token.d.ts:51:5 - error TS1170: A computed property name in a type literal must refer to an expression whose type is a literal type or a 'unique symbol' type.        
    
    51     [eIdentityComponents.OrganizationRoles]: import("@volo/abp.commercial.ng.ui/lib/models/props").PropContributorCallback<import("@volo/abp.commercial.ng.ui").EntityPropList<Identity.RoleItem>>[];
           ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
    node_modules/@volo/abp.ng.identity.config/lib/tokens/extensions.token.d.ts:51:26 - error TS2339: Property 'OrganizationRoles' does not exist on type 'typeof eIdentityComponents'.
    
    51     [eIdentityComponents.OrganizationRoles]: import("@volo/abp.commercial.ng.ui/lib/models/props").PropContributorCallback<import("@volo/abp.commercial.ng.ui").EntityPropList<Identity.RoleItem>>[];
                                ~~~~~~~~~~~~~~~~~
    
  • 0
    Mehmet created
    Support Team

    If you would like to use v2.7, add resolutions to package.json as shown below, remove yarn.lock and then run the yarn again.

    "dependencies": { ... },
    "resolutions": {
    "@volo/abp.commercial.ng.ui": "~2.7.0",
    "@volo/abp.ng.account.config": "~2.7.0",
    "@volo/abp.ng.audit-logging.config": "~2.7.0",
    "@volo/abp.ng.identity-server.config": "~2.7.0",
    "@volo/abp.ng.identity.config": "~2.7.0",
    "@volo/abp.ng.language-management.config": "~2.7.0",
    "@volo/abp.ng.saas.config": "~2.7.0",
    "@volo/abp.ng.text-template-management.config": "~2.7.0",
    }
    
  • 0
    vishalnikam created

    i tried this and it build succsfully but same issue. now language mangement is also not working

  • 0
    Mehmet created
    Support Team

    Can you provide the yarn list --pattern abp command result to us? The config packages (@volo/abp.ng.saas.config, etc.) versions should be v2.7. If you see V2.9, some things have gone wrong.

  • 0
    vishalnikam created

    yarn list v1.22.4 ├─ @abp/[email protected] ├─ @abp/[email protected]
    │ └─ @abp/[email protected] ├─ @abp/[email protected]
    │ └─ @abp/[email protected] ├─ @abp/[email protected] ├─ @abp/[email protected]
    │ └─ @abp/[email protected] ├─ @abp/[email protected] ├─ @abp/[email protected] ├─ @volo/[email protected] │ └─ @abp/[email protected] ├─ @volo/[email protected] ├─ @volo/[email protected] ├─ @volo/abp.ng.audit-logging.[email protected] ├─ @volo/[email protected] ├─ @volo/[email protected] ├─ @volo/[email protected] ├─ @volo/[email protected] ├─ @volo/[email protected] ├─ @volo/[email protected] ├─ @volo/[email protected] ├─ @volo/[email protected] ├─ @volo/[email protected] ├─ @volo/[email protected] ├─ @volo/[email protected] │ └─ @abp/[email protected] └─ @volo/[email protected]

  • 0
    Mehmet created
    Support Team

    Can you share your dependencies in package.json with us? It seems the versions of @volo/* packages is ~2.6.0. As you specified above, your ABP Framework version is v2.7.0. You should upgrade all @volo/* packages to v2.7.0

  • 0
    vishalnikam created

    { "name": "MyApplication", "version": "0.0.0", "scripts": { "ng": "ng", "start": "ng serve --open", "build": "ng build", "build:prod": "ng build --configuration production", "test": "jest", "lint": "ng lint", "e2e": "ng e2e" }, "private": true, "jest": { "preset": "jest-preset-angular", "setupFilesAfterEnv": [ "<rootDir>/setupJest.ts" ], "testPathIgnorePatterns": [ "<rootDir>/node_modules/", "<rootDir>/dist/", "<rootDir>/src/test.ts" ] }, "dependencies": { "@angular/animations": "~9.1.0", "@angular/cdk": "^9.2.4", "@angular/common": "~9.1.0", "@angular/compiler": "~9.1.0", "@angular/core": "~9.1.0", "@angular/forms": "~9.1.0", "@angular/material": "^9.2.4", "@angular/platform-browser": "~9.1.0", "@angular/platform-browser-dynamic": "~9.1.0", "@angular/router": "~9.1.0", "@types/jest": "^26.0.0", "@volo/abp.ng.account": "~2.6.2", "@volo/abp.ng.audit-logging": "~2.6.2", "@volo/abp.ng.identity": "~2.6.2", "@volo/abp.ng.identity-server": "~2.6.2", "@volo/abp.ng.language-management": "~2.6.2", "@volo/abp.ng.saas": "~2.6.2", "@volo/abp.ng.text-template-management": "^2.7.1", "@volo/abp.ng.theme.lepton": "~2.6.2", "jest": "^26.0.1", "jest-preset-angular": "^8.2.1", "rxjs": "~6.5.4", "tslib": "^1.10.0", "zone.js": "~0.10.2" }, "devDependencies": { "@angular-devkit/build-angular": "~0.901.0", "@angular-devkit/build-ng-packagr": "~0.901.0", "@angular/cli": "~9.1.0", "@angular/compiler-cli": "~9.1.0", "@angular/language-service": "~9.1.0", "@ngxs/logger-plugin": "^3.6.2", "@types/node": "^12.11.1", "codelyzer": "^5.1.2", "ng-packagr": "^9.0.0", "ngxs-schematic": "^1.1.9", "ts-node": "~8.3.0", "tslint": "~6.1.0", "typescript": "~3.8.3" } }

  • 0
    Mehmet created
    Support Team

    Please replace the package.json with below, remove yarn.lock file and run the yarn command. The problem will be resolved.

    {
      "name": "MyApplication",
      "version": "0.0.0",
      "scripts": {
        "ng": "ng",
        "start": "ng serve --open",
        "build": "ng build",
        "build:prod": "ng build --configuration production",
        "test": "jest",
        "lint": "ng lint",
        "e2e": "ng e2e"
      },
      "private": true,
      "jest": {
        "preset": "jest-preset-angular",
        "setupFilesAfterEnv": [
          "<rootDir>/setupJest.ts"
        ],
        "testPathIgnorePatterns": [
          "<rootDir>/node_modules/",
          "<rootDir>/dist/",
          "<rootDir>/src/test.ts"
        ]
      },
      "dependencies": {
        "@abp/ng.setting-management": "~2.7.0",
        "@angular/animations": "~9.1.0",
        "@angular/cdk": "^9.2.4",
        "@angular/common": "~9.1.0",
        "@angular/compiler": "~9.1.0",
        "@angular/core": "~9.1.0",
        "@angular/forms": "~9.1.0",
        "@angular/material": "^9.2.4",
        "@angular/platform-browser": "~9.1.0",
        "@angular/platform-browser-dynamic": "~9.1.0",
        "@angular/router": "~9.1.0",
        "@types/jest": "^26.0.0",
        "@volo/abp.ng.account": "~2.7.0",
        "@volo/abp.ng.audit-logging": "~2.7.0",
        "@volo/abp.ng.identity": "~2.7.0",
        "@volo/abp.ng.identity-server": "~2.7.0",
        "@volo/abp.ng.language-management": "~2.7.0",
        "@volo/abp.ng.saas": "~2.7.0",
        "@volo/abp.ng.text-template-management": "~2.7.0",
        "@volo/abp.ng.theme.lepton": "~2.7.0",
        "jest": "^26.0.1",
        "jest-preset-angular": "^8.2.1",
        "rxjs": "~6.5.4",
        "tslib": "^1.10.0",
        "zone.js": "~0.10.2"
      },
      "devDependencies": {
        "@angular-devkit/build-angular": "~0.901.0",
        "@angular-devkit/build-ng-packagr": "~0.901.0",
        "@angular/cli": "~9.1.0",
        "@angular/compiler-cli": "~9.1.0",
        "@angular/language-service": "~9.1.0",
        "@ngxs/logger-plugin": "^3.6.2",
        "@types/node": "^12.11.1",
        "codelyzer": "^5.1.2",
        "ng-packagr": "^9.0.0",
        "ngxs-schematic": "^1.1.9",
        "ts-node": "~8.3.0",
        "tslint": "~6.1.0",
        "typescript": "~3.8.3"
      },
      "resolutions": {
        "@abp/ng.core": "~2.7.0",
        "@abp/ng.feature-management": "~2.7.0",
        "@abp/ng.theme.shared": "~2.7.0",
        "@abp/ng.permission-management": "~2.7.0",
        "@abp/ng.setting-management.config": "~2.7.0",
        "@abp/utils": "~2.7.0",
        "@volo/abp.commercial.ng.ui": "~2.7.0",
        "@volo/abp.ng.account.config": "~2.7.0",
        "@volo/abp.ng.audit-logging.config": "~2.7.0",
        "@volo/abp.ng.language-management.config": "~2.7.0",
        "@volo/abp.ng.identity-server.config": "~2.7.0",
        "@volo/abp.ng.identity.config": "~2.7.0",
        "@volo/abp.ng.saas.config": "~2.7.0",
        "@volo/abp.ng.text-template-management.config": "~2.7.0"
      }
    }
    

    If you upgrade the ABP version to the latest, you don't need to add resolutions to package.json.

    See the new versions after configuration above: