Open Closed

@abp/ng.theme.shared 5.1.3 has unexpected dependencies #2627


0
N335378 created

We get Warnings suggesting abp theme shared has hidden dependencies to older versions of angular ? Please advise

Upon further examination below, we can see that abp theme shared depends on @swimlane/[email protected]

> yarn why @swimlane/ngx-datatable
yarn why v1.22.17
[1/4] Why do we have the module "@swimlane/ngx-datatable"...?
[2/4] Initialising dependency graph...
[3/4] Finding dependency...
[4/4] Calculating file sizes...
=> Found "@swimlane/[email protected]"
info Reasons this module exists
   - "@abp#ng.theme.shared" depends on it
   - Hoisted from "@abp#ng.theme.shared#@swimlane#ngx-datatable"
info Disk size without dependencies: "5.1MB"
info Disk size with unique dependencies: "5.17MB"
info Disk size with transitive dependencies: "5.17MB"
info Number of shared dependencies: 1
Done in 1.13s.
  • ABP Framework version: v5.1.3
  • UI type: Angular 13
  • DB provider: EF Core / postgres
  • Tiered (MVC) or Identity Server Separated (Angular): separate
  • Exception message and stack trace:
* warning "@abp/ng.account > @abp/ng.theme.shared > @ngx-validate/[email protected]" has incorrect peer dependency "@angular/[email protected]>=5.0.0 <11.0.0".
warning "@abp/ng.account > @abp/ng.theme.shared > @ngx-validate/[email protected]" has incorrect peer dependency "@angular/[email protected]>=5.0.0 <11.0.0".
warning "@abp/ng.account > @abp/ng.theme.shared > @ngx-validate/[email protected]" has incorrect peer dependency "@angular/[email protected]>=5.0.0 <11.0.0".
warning "@abp/ng.account > @abp/ng.theme.shared > @swimlane/[email protected]" has incorrect peer dependency "@angular/[email protected]^11.0.2".
warning "@abp/ng.account > @abp/ng.theme.shared > @swimlane/[email protected]" has incorrect peer dependency "@angular/[email protected]^11.0.2".
warning "@abp/ng.account > @abp/ng.theme.shared > @swimlane/[email protected]" has incorrect peer dependency "@angular/[email protected]^11.0.2".
  • Steps to reproduce the issue:" Run .\start.ps1

1 Answer(s)
  • 0
    muhammedaltug created
    Support Team

    Hello,

    Sorry for the late response.

    Thanks for reporting the issue.

    These warnings are not a blocker for your application.

    We will update the ngx-datatable package version to 20 at ABP 5.3 version.

    If you want to update this package in your project please add the following lines in your package.json

      "resolutions": {
        "@swimlane/ngx-datatable": "20.0.0"
      }