Open Closed

Show accountlayout on login screen #2959


0
safi created

Hi

I want to show the account layout UI on the login screen. I am using commercial abp blazor io project and the login screen comes with no theme only login forms come so can we show the layout here same as we show after login but before login, we will hide all menus.

  • ABP Framework version: v4.43
  • UI type: Blazor
  • DB provider: EF Core
  • Tiered (MVC) or Identity Server Separated (Angular): no
  • Exception message and stack trace:
  • Steps to reproduce the issue:"

39 Answer(s)
  • 0
    liangshiwei created
    Support Team

    Hi,

    You can change the layout.

    @{
        Layout = ThemeManager.CurrentTheme.GetApplicationLayout();
    }
    
  • 0
    safi created

    Hi,

    You can change the layout.

    @{ 
        Layout = ThemeManager.CurrentTheme.GetApplicationLayout(); 
    } 
    

    yes, thanks for the reply it's working but can we show a layout like this.

    Current layout :

    Needed layout

  • 0
    liangshiwei created
    Support Team

    Yes, you can change the layout name.

    @{ 
        Layout = ...your layout name
    } 
    
  • 0
    safi created

    Yes, you can change the layout name.

    @{  
        Layout = ...your layout name 
    }  
    

    I don't have any customized layout but the problem is this screen comes from blazor and the other screen comes from the host.

  • 0
    safi created

    Yes, you can change the layout name.

    @{  
        Layout = ...your layout name 
    }  
    

    In host, we don't have lepton them and in blazor we have so how can I add lepton in the host project so it will resolve this.

  • 0
    safi created

    Yes, you can change the layout name.

    @{   
        Layout = ...your layout name  
    }   
    

    In host, we don't have lepton them and in blazor we have so how can I add lepton in the host project so it will resolve this.

    Is there anyone to check this and provide solution

  • 0
    liangshiwei created
    Support Team
    1. abp add-package Volo.Abp.AspNetCore.Mvc.UI.Theme.Lepton
    2. Add "@volo/abp.aspnetcore.mvc.ui.theme.lepton": "your version" to package.json
    3. Run abp install-libs
  • 0
    safi created
    1. abp add-package Volo.Abp.AspNetCore.Mvc.UI.Theme.Lepton
    2. Add "@volo/abp.aspnetcore.mvc.ui.theme.lepton": "your version" to package.json
    3. Run abp install-libs

    above command needs to run in command prompt?

  • 0
    safi created

    @volo/abp.aspnetcore.mvc.ui.theme.lepton

    It's already added in package.json

    how can I show lepton theme in host project

  • 0
    liangshiwei created
    Support Team

    In host, we don't have lepton them and in blazor we have so how can I add lepton in the host project so it will resolve this. above command needs to run in command prompt

    In your case, should be in the host project folder.

    BTW, I remember that the lepton theme should be pre-installed when you use the ABP suite to create a new project.

    how can I show lepton theme in host project

    When you have done all things, it should be working.

  • 0
    safi created

    In host, we don't have lepton them and in blazor we have so how can I add lepton in the host project so it will resolve this. above command needs to run in command prompt

    In your case, should be in the host project folder.

    BTW, I remember that the lepton theme should be pre-installed when you use the ABP suite to create a new project.

    how can I show lepton theme in host project

    When you have done all things, it should be working.

    This is my host project packages

    Package.json

  • 0
    safi created

    In host, we don't have lepton them and in blazor we have so how can I add lepton in the host project so it will resolve this. above command needs to run in command prompt

    In your case, should be in the host project folder.

    BTW, I remember that the lepton theme should be pre-installed when you use the ABP suite to create a new project.

    how can I show lepton theme in host project

    When you have done all things, it should be working.

    Can we just connect for 5 mins on zoom?

  • 0
    liangshiwei created
    Support Team

    Hi,

    You can try it first, I think it should be easy to do.

  • 0
    safi created

    Hi,

    You can try it first, I think it should be easy to do.

    Getting this error

  • 0
    safi created

    Hi,

    You can try it first, I think it should be easy to do.

    Getting this error

    Are you there?

  • 0
    gterdem created
    Support Team

    Try abp install-libs command under the project you are getting this error.

  • 0
    safi created

    abp install-libs

    It's already installed in host project and after running getting above error

  • 0
    safi created

    Hi,

    You can try it first, I think it should be easy to do.

    Can we check this pls

  • 0
    safi created

    Hi,

    You can try it first, I think it should be easy to do.

    Can we check this pls

    Is anyone there?

  • 0
    safi created

    abp install-libs

    I am using 4.4.3 abp version and it's installing the latest one so can we give version in this.

  • 0
    liangshiwei created
    Support Team

    Hi,

    I am using 4.4.3 abp version

    It should be ~4.3.3 if you are using version 4.4.3

  • 0
    safi created

    abp install-libs

    I am using 4.4.3 abp version and it's installing the latest one so can we give version in this.

    Hi liangshiwei

    can u pls check this

  • 0
    liangshiwei created
    Support Team

    HI,

    join the meeting: https://zoom.us/j/99950578218?pwd=YTEzTG5Jb2ZQeWVwWWo0aUNGdlpWUT09

  • 0
    liangshiwei created
    Support Team

    Solved

  • 0
    safi created

    Solved

    After adding ABP libs into the host project and changing the environment to the production site is not working. It's throwing a 500 error and If I check in the log file the getting below error

  • 0
    liangshiwei created
    Support Team

    Hi,

    I think this is not related to ABP

    Please check your global.js code

  • 0
    safi created

    Hi,

    I think this is not related to ABP

    Please check your global.js code

    Hi liangshiwel

    Thanks for your suggestions and solution. It's working fine on local but if I am deploying code on my test server then all is working fine except the login screen UI. In login UI is not coming properly also no errors are coming in the console as well.

    Can you suggest to me what I can do in this case?

  • 0
    liangshiwei created
    Support Team

    Hi,

    See: https://docs.abp.io/en/abp/latest/UI/AspNetCore/Bundling-Minification#ignore-for-minification

    You can try to ignoring the global.js file.

  • 0
    safi created

    Hi,

    See: https://docs.abp.io/en/abp/latest/UI/AspNetCore/Bundling-Minification#ignore-for-minification

    You can try to ignoring the global.js file.

    I already removed this. On local it's taking CSS from global-style.css file but if we are deploying code it's taking references from file this is the issue.

  • 0
    liangshiwei created
    Support Team

    Hi,

    I think we are talking about js not css.

    However, if you don't want to use bundles & minifies, you can change it. see: https://docs.abp.io/en/abp/latest/UI/AspNetCore/Bundling-Minification#bundling-mode

  • 0
    safi created

    Hi,

    I think we are talking about js not css.

    However, if you don't want to use bundles & minifies, you can change it. see: https://docs.abp.io/en/abp/latest/UI/AspNetCore/Bundling-Minification#bundling-mode

    Not able to understand why it's not loading HTML properly on test server

    On local login HTML is

  • 0
    liangshiwei created
    Support Team

    Did you try this?

    Configure<AbpBundlingOptions>(options =>
    {
        options.Mode = BundlingMode.None;
    });
    
  • 0
    safi created

    Did you try this?

    Configure<AbpBundlingOptions>(options => 
    { 
        options.Mode = BundlingMode.None; 
    }); 
    

    yes

  • 0
    liangshiwei created
    Support Team

    You can try to ignoring the global.js file.

    When you ignore the global.js file, is it working?

    Actually, we recommend using the bundling system, because It can effectively reduce the size of CSS and JS files to makes your app load faster.

    If everything is ok, you don't have to care about it

  • 0
    safi created

    You can try to ignoring the global.js file.

    When you ignore the global.js file, is it working?

    Actually, we recommend using the bundling system, because It can effectively reduce the size of CSS and JS files to makes your app load faster.

    If everything is ok, you don't have to care about it

    I already removed this

  • 0
    liangshiwei created
    Support Team

    Is there any problem?

  • 0
    safi created

    Is there any problem? Tried all things but no luck. It's looking like a blocker for us and because of this we are not able to deliver project.

  • 0
    liangshiwei created
    Support Team

    https://zoom.us/j/96542343855?pwd=YUZvWjBoMEdSS2w3Y2xhelh6MHU2Zz09

  • 0
    liangshiwei created
    Support Team

    Hi,

    You can change the layout.

    @{ 
        Layout = ThemeManager.CurrentTheme.GetApplicationLayout(); 
    } 
    

    Solved, you missed this.