Open Closed

Tenant not Found. Urgent Production Issue #3282


0
[email protected] created

Hi

Already we have raised multiple tickets for this issue . Ticket ids 2271 & 2507. The Solution provided in the tickets are not working.

Already tried ugrading the ABP Solution version from 4.4.2 to 5 but it throws run time exception and the service is not getting started.

We have used the Application Template for creating a solution.

As the product is live , need this to be resolved on priority. I would request a screen sharing session to solve this issue.


13 Answer(s)
  • 0
    berkansasmaz created
    Support Team

    Hi

    I will test the situation in version 4.4.2 as soon as possible and reply to you.

  • 0
    berkansasmaz created
    Support Team

    Hello, I tried to reproduce the problem but unfortunately, I couldn't reproduce it. There is no need to repeat what has been said in other tickets, so if you can provide a minimally reproducible example, we will be able to better detect and solve the problem.

  • 0
    [email protected] created

    Hello, I tried to reproduce the problem but unfortunately, I couldn't reproduce it. There is no need to repeat what has been said in other tickets, so if you can provide a minimally reproducible example, we will be able to better detect and solve the problem.

    Hi

    Will share the source both service and angular with you today. Pls reproduce the same and let me know.

    Thanks

  • 0
    berkansasmaz created
    Support Team

    Hello again, I am looking forward to the minimal reproducible example of the problem.

  • 0
    [email protected] created

    Hi

    [I deleted the url for security reasons. - berkansasmaz]

    The link has both the angular and aspnet core files. Please do let me know if you need more details.

  • 0
    berkansasmaz created
    Support Team

    Hi again, sorry but I can't reproduce the problem. After running the project, I created a tenant and logged in to the application with that tenant's admin user, then I waited for 10 minutes, but I could not see a problem. Is there something I missed? Please guide me so that I can reproduce the error.

  • 0
    [email protected] created

    There are other applications generated using abp suite which refers this application for Identity Server. Will there be a problem using that. If I can send that service as well will you be able to replicate.

    If needed I can do a screen sharing as well to show you the same.

  • 0
    berkansasmaz created
    Support Team

    Can you provide an online website?

  • 0
    [email protected] created

    It will be difficult to provide a online website. can we do a screen sharing,

  • 0
    berkansasmaz created
    Support Team

    Got it, I'm going to add a module to the sample application you provided and try to reproduce the problem.

  • 0
    berkansasmaz created
    Support Team

    The tenant exists in the database but still we are getting this error. Step 1: The user is using the applicaiton for say 10 minutes. Step2 : After say 10 mins when trying to access the application we get this error, Tenant not found. Step 3: After clearing cache ,it works.

    Hello, can we just turn off Redis temporarily? I know the application will be very slow, but we will see if the problem is entirely with Redis.

  • 0
    [email protected] created

    Will try by turning off the Redis and see if it works. Is it ok if I can change only in the configuration.

  • 0
    berkansasmaz created
    Support Team

    Yes, it may be enough to change the configuration so that it cannot access the Redis server.