Open Closed

how add Volo.TextTemplateManagement in Module Template (.NET & Angular) #3507


0
[email protected] created

how add Volo.TextTemplateManagement in Module Template (.NET & Angular)?

https://docs.abp.io/en/commercial/latest/modules/text-template-management#how-to-install

  • ABP Framework version: v5.1.3
  • UI type: Angular
  • DB provider: EF Core
  • Tiered (MVC) or Identity Server Separated (Angular): yes

6 Answer(s)
  • 0
    EngincanV created
    Support Team

    Hi, you can run the following command on the root directory of your project to add the Volo.TextTemplateManagement to your project:

    abp add-module Volo.TextTemplateManagement
    
  • 0
    [email protected] created

    Hi, abp add-module Volo.TextTemplateManagement

    only in .net core , but don't add in angular project

  • 0
    EngincanV created
    Support Team

    Hi, abp add-module Volo.TextTemplateManagement

    only in .net core , but don't add in angular project

    To install it for Angular UI, please see https://docs.abp.io/en/commercial/latest/modules/text-template-management#angular-ui .

  • 0
    [email protected] created

    API HOST

    Angular

    core.mjs:6461 ERROR NullInjectorError: R3InjectorError(TextTemplateManagementModule)[ConfigStateService -> ConfigStateService -> ConfigStateService -> AbpApplicationConfigurationService -> RestService -> InjectionToken CORE_OPTIONS -> InjectionToken CORE_OPTIONS -> InjectionToken CORE_OPTIONS]: NullInjectorError: No provider for InjectionToken CORE_OPTIONS! at NullInjector.get (core.mjs:11095:1) at R3Injector.get (core.mjs:11262:1) at R3Injector.get (core.mjs:11262:1) at R3Injector.get (core.mjs:11262:1) at injectInjectorOnly (core.mjs:4741:1) at Module.ɵɵinject (core.mjs:4745:1) at Object.RestService_Factory [as factory] (abp-ng.core.mjs:337:1) at R3Injector.hydrate (core.mjs:11435:1) at R3Injector.get (core.mjs:11251:1) at injectInjectorOnly (core.mjs:4741:1)

  • 1
    muhammedaltug created
    Support Team

    Hello,

    Can you remove your node_modules folder and yarn.lock or package-lock.json? Then install packages with the yarn command.

    I think the installed text template package version is 5.1.4 and other ABP angular packages are 5.1.3.

  • 0
    [email protected] created

    Thanks, @EngincanV and @muhammedaltug