Open Closed

Cannot read the template Volo.Abp.Commercial.SuiteTemplates.Templates.Frontend.Blazor.ObjectMapping.BlazorAutoMapperProfile.txt #3848


0
mikeolofernes created

I upgraded ABP 5.3.4 to 6.0. I updated the packages, NPM and ABP suite, cli etc then this error occured

: If you're creating a bug/problem report, please include followings

  • ABP Framework version: v6.0
  • UI type: Blazor
  • DB provider: EF Core / Postgre
  • Tiered (MVC) or Identity Server Separated (Angular): yes
  • Exception message and stack trace:
  • Steps to reproduce the issue:"

5 Answer(s)
  • 0
    malik.masis created
    Support Team

    Hi,

    It should be UrlShortingMiddleware. There is a typo on the screenshot. Could you check it, please?

    Regards.

  • 0
    mikeolofernes created

    Hi,

    It should be UrlShortingMiddleware. There is a typo on the screenshot. Could you check it, please?

    Regards.

    Hi Malik,

    I tried it. The build is working but when I update existing Entities (which I created while on ABP 5.3.4 version) this error appear.

    It also says that the Entity I update is already existing.

    Hope you can help me with this issue.

    Thanks, Mike

  • 0
    malik.masis created
    Support Team

    Hi Mike,

    Just to make sure, do you try to update your CLI and then build/run your project? (Btw, Could you do abp clean then dotnet build /graphubild under the solution) Do I understand correctly?

    Because it seems to be a different issue related to migration.

    Regards

  • 0
    mikeolofernes created

    Hi Mike,

    Just to make sure, do you try to update your CLI and then build/run your project?
    (Btw, Could you do abp clean then dotnet build /graphubild under the solution) Do I understand correctly?

    Because it seems to be a different issue related to migration.

    Regards

    Did the abp clean. I did the dotnet build /graphbuild while we were on abp 5.3.4. Might be a different issue but its on the same topic that we encounter this error when we update the existing project to 6.0. Is there a complete step by step document on upgrading from ABP 5.3.4 to 6.0?

    Thanks, Mike

  • 0
    malik.masis created
    Support Team

    Hi Mike,

    There is documentation regarding migration from 5.3 to 6.0. There are base topics, and you can also find more detail by going to the specific ones.

    Btw, Could you look at the migration side in the documentation regarding IsActive column, please? The above migration error makes coming to mind.

    Regards