Open Closed

Project Not Found error when using abp generate-proxy -t ng #4063


0
bqabani created

ABP Framework version: v4.2.1

UI type: Angular

DB provider: EF Core

Tiered (MVC) or Identity Server Separated (Angular): no

Steps to reproduce the issue:"

Node Js: v14.18.0 npm: 8.1.4 yarn : 1.22.5

When I run (abp generate-proxy -t ng) in terminal I get this error:

[10:46:47 INF] ABP CLI (https://abp.io)
[10:46:47 INF] Version 4.2.2 (Stable)
[10:46:48 WRN] ABP CLI has a newer stable version 6.0.1, please update to get the latest features and fixes.
[10:46:48 WRN] 
[10:46:48 WRN] Update Command:
[10:46:48 WRN] dotnet tool update -g Volo.Abp.Cli
[10:46:48 WRN]
[10:46:48 WRN] Couldn't determinate version of "@abp/ng.schematics" package.
"SchematicsAbpGenerateProxy" schema is using the keyword "id" which its support is deprecated. Use "$id" for schema ID.
[Project Not Found] Either define a default project in your workspace or specify the project name in schematics options.

I tried to change the id property to schema files in my node_modules folder, so I could get rid of the warning but I still get the same error in last line:

[10:49:13 INF] ABP CLI (https://abp.io)
[10:49:14 INF] Version 4.2.2 (Stable)
[10:49:15 WRN] ABP CLI has a newer stable version 6.0.1, please update to get the latest features and fixes.
[10:49:15 WRN]
[10:49:15 WRN] Update Command:
[10:49:15 WRN] dotnet tool update -g Volo.Abp.Cli
[10:49:15 WRN]
[10:49:15 WRN] Couldn't determinate version of "@abp/ng.schematics" package.
[Project Not Found] Either define a default project in your workspace or specify the project name in schematics options.

I found that I have in my dev dependencies: "@abp/ng.schematics": "^4.3.3" so I downgraded it to "@abp/ng.schematics": "^4.2.1" but still the same error

I tried removing node modules and installing it, I get the same errors

I tried to use abp 4.2.2 or 4.2.1 , I get the same errors

Please note that the system was working but when I upgraded the abp and nodejs and then I rolled back to the same old versions I got the errors above


11 Answer(s)
  • 0
    kirotech created

    same error here after upgrade to 6.0.1 from 5.x.x

  • 0
    muhammedaltug created
    Support Team

    Hello,

    What is your angular version?

    Is the defaultProject property exists in your angular.json?

    We know defaultProject deprecated with angular 14. And we fixed proxy generation. The fix will be available in 6.0.2

  • -1
    bqabani created

    The defaultProject in angular.json is already set to my project correctly, I did not change it and it was working.

    Angular CLI: 12.0.5 Node: 14.18.0 Package Manager: yarn 1.22.5 OS: win32 x64 Angular: 12.0.5

    and this is a subset of my packages: "@abp/ng.components": "~4.2.1", "@abp/ng.core": "~4.2.1", "@abp/ng.setting-management": "~4.2.1", "@abp/ng.theme.shared": "~4.2.1", "@angular-devkit/build-ng-packagr": "^0.1002.0", "@angular/animations": "~12.0.2", "@angular/common": "~12.0.2", "@angular/compiler": "~12.0.2", "@angular/core": "~12.0.2", "@angular/fire": "^6.1.5", "@angular/forms": "~12.0.2", "@angular/platform-browser": "~12.0.2", "@angular/platform-browser-dynamic": "~12.0.2", "@angular/router": "~12.0.2", "@volo/abp.commercial.ng.ui": "~4.2.1", "@volo/abp.ng.account": "~4.2.1", "@volo/abp.ng.audit-logging": "~4.2.1", "@volo/abp.ng.identity": "~4.2.1", "@volo/abp.ng.identity-server": "~4.2.1", "@volo/abp.ng.language-management": "~4.2.1", "@volo/abp.ng.saas": "~4.2.1", "@volo/abp.ng.text-template-management": "~4.2.1", "@volo/abp.ng.theme.lepton": "~4.2.1", on devDependencies:

    I tried: "devDependencies": { "@abp/ng.schematics": "^4.2.1" and tried "@abp/ng.schematics": "^4.3.3", "@angular-devkit/build-angular": "^12.0.5", "@angular/cli": "^12.0.5", "@angular/compiler-cli": "~12.0.2", "@angular/language-service": "~12.0.2", "@types/jasmine": "~3.5.0", "@types/jasminewd2": "~2.0.3", "@types/node": "^12.11.1",

    I did not understand your last post line, do you want me to upgrade abp cli to 6.0.2? what about other tools?

  • -1
    bqabani created

    Any update Please :) ?

  • -1
    LinchArnold created

    Hello,

    What is your angular version?

    Is the defaultProject property exists in your angular.json?

    We know defaultProject deprecated with angular 14. And we fixed proxy generation. The fix will be available in 6.0.2

    Same error here, abp version 6.0.1, prompt enter target Angular project to place the generated code. when execute generate-proxy -t ng for the Application Module project type. So what's the time for releasing 6.0.2?

  • -3
    bqabani created

    Hello,

    What is your angular version?

    Is the defaultProject property exists in your angular.json?

    We know defaultProject deprecated with angular 14. And we fixed proxy generation. The fix will be available in 6.0.2

    Same error here, abp version 6.0.1, prompt enter target Angular project to place the generated code. when execute generate-proxy -t ng for the Application Module project type. So what's the time for releasing 6.0.2?

    That does not solve the problem!

    Dear Support team, any update on the original issue?

  • 1
    LinchArnold created

    Hello,

    What is your angular version?

    Is the defaultProject property exists in your angular.json?

    We know defaultProject deprecated with angular 14. And we fixed proxy generation. The fix will be available in 6.0.2

    Same error here, abp version 6.0.1, prompt enter target Angular project to place the generated code. when execute generate-proxy -t ng for the Application Module project type.

    So what's the time for releasing 6.0.2?

    That does not solve the problem!

    Dear Support team, any update on the original issue?

    Open your eyes widely please! I am not the abp team member, I am just came across the same errors as you. Just provide a additional evidence that abp 6.0.1 also has this bug. so it absolutely can not solve your problem. So see clearly what the other person said next time before your next reply, is that ok?

  • -1
    bqabani created

    Dear Support team, any update on the original issue?

  • 2
    scott7106 created

    And we fixed proxy generation. The fix will be available in 6.0.2

    @muhammedalhug You indicated in the thread above that a fix for proxy generation would be in 6.0.2. Is there a timeframe on that release?

  • 0
    EngincanV created
    Support Team

    @muhammedalhug You indicated in the thread above that a fix for proxy generation would be in 6.0.2. Is there a timeframe on that release?

    6.0.2 was released yesterday.

  • 0
    muhammedaltug created
    Support Team

    Hello,

    @bqabani can you try without -t paramter abp generate-proxy, -t means target in your version. You can read more details in document