Open Closed

Issues with module template in ABP 7 #4403


0
[email protected] created
  • ABP Framework version: v7.0.0

  • UI type: Angular

  • DB provider: EF Core

  • Steps to reproduce the issue:

I am having a few issues with the module template. I created a new module solution in abp suite and set it up using the below guide :

https://docs.abp.io/en/abp/latest/Startup-Templates/Module#how-to-start-with

I have added a core module to the main solution using the abp suite and was able to add an entity to core as well. The suite only generates mvc frontend and does not generate any angular files. How could we generate angular files as well for the new entities? I am also having issues generating proxies for the entities. I get the same error even after specifying the module. Kindly advise

abp generate-proxy -t ng ABP CLI 7.0.0 DEPRECATED: The 'defaultProject' workspace option has been deprecated. The project to use will be determined from the current working directory. [Invalid Module] Backend module "app" does not exist in API definition.

abp generate-proxy -t ng -m dev-app
ABP CLI 7.0.0 DEPRECATED: The 'defaultProject' workspace option has been deprecated. The project to use will be determined from the current working directory. [Invalid Module] Backend module "dev-app" does not exist in API definition.


3 Answer(s)
  • 0
    gterdem created
    Support Team

    This was a bug and shoud've been fixed at version 7.0.1 patch. Can you try with the preview version?

    I have refunded your question.

  • 0
    [email protected] created

    I am still facing the same issue with ABP 7.0.1 as well. Please find the logs below. I have noticed that the issue is with only modules created in a project created with the module startup template but angular components and proxies are generated in modules created within a project created using an application startup template. Is there a workaround available to for the same?

  • 0
    mahmut.gundogdu created
    Support Team

    I have tested with the latest stable version of ABP cli and suite (7.0.1). It works as expected. There is no error. Please double-check that the migration and database have been updated. When you are using the module template, Suite does not create and execute migrations.

    When you are using module template, you should execute commend like

    abp generate-proxy -t ng -m yourModuleName -a YourModuleName --target yourModuleName

    example: My Module name is Questions4403

    abp generate-proxy -t ng -m questions4403 -a Questions4403 --target questions4403

    check the ABP generate-proxy doc https://docs.abp.io/en/abp/latest/CLI#generate-proxy