Open Closed

Error Generate CRUD Page #58


0
[email protected] created

Hi,

I'm facing a problem that I cannot generate CRUD page using ABP Suite although I can build success the whole solution

Where can I find the log when using ABP Suite ?

Update: After diging, I can find the Abp suite's logs where is %userprofile%.abp\suite\logs

But there is no any Error in the log

2020-03-13 10:19:33.094 +07:00 [INF] Request starting HTTP/1.1 GET http://localhost:3000/api/abpSuite/solutions/DDC.BackendService/is-built application/json 2020-03-13 10:19:33.094 +07:00 [INF] Executing endpoint 'Volo.Abp.Suite.Controllers.AbpSuiteController.IsSolutionBuiltAsync (Volo.Abp.Suite)' 2020-03-13 10:19:33.095 +07:00 [INF] Route matched with {action = "IsSolutionBuilt", controller = "AbpSuite", area = "", page = ""}. Executing controller action with signature System.Threading.Tasks.Task1[System.Boolean] IsSolutionBuiltAsync(System.String) on controller Volo.Abp.Suite.Controllers.AbpSuiteController (Volo.Abp.Suite). 2020-03-13 10:19:33.098 +07:00 [INF] Executing ObjectResult, writing value of type 'System.Boolean'. 2020-03-13 10:19:33.098 +07:00 [INF] Executed action Volo.Abp.Suite.Controllers.AbpSuiteController.IsSolutionBuiltAsync (Volo.Abp.Suite) in 3.5566ms 2020-03-13 10:19:33.098 +07:00 [INF] Executed endpoint 'Volo.Abp.Suite.Controllers.AbpSuiteController.IsSolutionBuiltAsync (Volo.Abp.Suite)' 2020-03-13 10:19:33.098 +07:00 [INF] Request finished in 4.6486ms 200 application/json; charset=utf-8 2020-03-13 10:19:34.111 +07:00 [INF] Request starting HTTP/1.1 POST http://localhost:3000/api/abpSuite/solutions/DDC.BackendService/build application/json 0 2020-03-13 10:19:34.111 +07:00 [INF] Executing endpoint 'Volo.Abp.Suite.Controllers.AbpSuiteController.BuildSolutionAsync (Volo.Abp.Suite)' 2020-03-13 10:19:34.111 +07:00 [INF] Route matched with {action = "BuildSolution", controller = "AbpSuite", area = "", page = ""}. Executing controller action with signature System.Threading.Tasks.Task1[System.Boolean] BuildSolutionAsync(System.String) on controller Volo.Abp.Suite.Controllers.AbpSuiteController (Volo.Abp.Suite). 2020-03-13 10:19:36.844 +07:00 [INF] Executing ObjectResult, writing value of type 'System.Boolean'. 2020-03-13 10:19:36.844 +07:00 [INF] Executed action Volo.Abp.Suite.Controllers.AbpSuiteController.BuildSolutionAsync (Volo.Abp.Suite) in 2732.9898ms 2020-03-13 10:19:36.844 +07:00 [INF] Executed endpoint 'Volo.Abp.Suite.Controllers.AbpSuiteController.BuildSolutionAsync (Volo.Abp.Suite)' 2020-03-13 10:19:36.844 +07:00 [INF] Request finished in 2733.7561ms 200 application/json; charset=utf-8


4 Answer(s)
  • 0
    hikalkan created

    Can you try to install the latest .net core SDK (v3.1.102)? https://dotnet.microsoft.com/download/dotnet-core/thank-you/sdk-3.1.102-windows-x64-installer

  • 0
    alper created

    check that the solution path is still valid. sometimes people move solution directory and then this error is shown up!

  • 0
    [email protected] created

    @hikalkan: I installed the lastest .net core but I still cannot generate CRUD page @alper: Yes maybe I created the solution using abp suite and then change the directory, then I added the existing solution using Suite. How can I handle this ?

    I also try to create a new solution without editing anything. And then generate CRUD page but It still shows the same Error above

  • 0
    alper created

    hi,

    This has been fixed in the new version. If you have time, it'll be released on 2020-03-19.