Open Closed

Cannot load Administration menu #66


1
DRPDEV created

I 'm using Abp Suite 2.3.0 to create a new solution with options (UI framework: Angular; Mobile: React Native; Database Provider: Entity Framework Core; Separate Identity Server). But, when i launch front-end web site, it doesn't contain The Administration menu (this issue didn't happened in the Abp Suite 2.2.1). How i can fix it? And another question: how can i test the web api in the Swagger UI when Separate Identity Server options is selected?


10 Answer(s)
  • 0
    Mehmet created

    For your first question;

    • Make sure to clean the storages
    • The issuer property in the environment must match the running address of .IdentityServer project
  • 0
    DRPDEV created

    Note: My pc in behind a coporation proxy and cannot connect to github. Is there any problem about that?

  • 0
    alper created

    no! there's nothing to do with GitHub.

  • 0
    alper created

    To test via Swagger, run the Acme.BookStore.HttpApi.Host project https://localhost:44314/swagger/index.html

  • 0
    DRPDEV created

    But when i try to call an api on Swagger, i get error message "Authorization failed! ..." Note: I has created solution with option "Separate Identity Server" and launch it before Acme.BookStore.HttpApi.Host.

  • 0
    alper created

    Swagger doesn't allow Seperate Identity Server authentication. I think this is an issue to be solved by Swagger.

  • 0
    DRPDEV created

    But I got an error with Abp Suite when Create New Solution as below:

    Note: My PC is behind a Corporator Proxy, and don't allow access to Github.

  • 0
    alper created

    So that's the problem. Can you connect to the internet via your phone's wifi to understand the issue. If so, you might request your computer to access to the GitHub domain from your administrator.

  • 0
    zony created

    I 'm using Abp Suite 2.3.0 to create a new solution with options (UI framework: Angular; Mobile: React Native; Database Provider: Entity Framework Core; Separate Identity Server). But, when i launch front-end web site, it doesn't contain The Administration menu (this issue didn't happened in the Abp Suite 2.2.1). How i can fix it?

    **I have the problem too! When ui framework is angular, the administration menus are not showed; when ui framework is mvc, it works. **

  • 0
    alper created

    see https://support.abp.io/QA/Questions/5#answer-a7176f3f-c297-c06c-0923-39f30889b0c3 basically clearing the local storage and session storage should fix it.