Open Closed

abp suite - AppUser as navigation property is not working #1263


2
beuko created
  • ABP Framework version: v4.3.0
  • UI type: Angular
  • DB provider: EF Core
  • Tiered (MVC) or Identity Server Separated (Angular): no
  • Exception message and stack trace:
  • Steps to reproduce the issue:

Hi.

I created new project with abp suite (application template / angular / ef core / sql server). I migrated db and created new entity Notes and added required field Title. Then I tried to add navigation property AppUser (one-to-many relationship... one note can have one appuser ("autor"), but one appuser can have multiple notes).

I followed this guide LINK but i keep getting error The property 'AppUser.ExtraProperties' could not be mapped. I already looked on forums and github, but can not fix this issue.

In abp suite 4.3.0 entity class, dto class and mapping is already created when project is created. I defined navigation property just like in guide and still no success. Am I missing something?

Thanks for answers.


6 Answer(s)
  • 0
    jhsanc created

    I have the same problem.

  • 0
    Buckoge created

    I have the same problem, after migrating to 4.3 and basic using the suite, when I click the pick button on the modal the following error comes out: VM439:33 Uncaught TypeError: Cannot read property 'getPlaceLookup' of undefined at serviceMethod (<anonymous>:33:73)...

  • 0
    christophe.baille created

    I have a similar issue after I migrate to 4.3.

    I migrate from 4.21 to 4.3, then I did notice that when I regenerate entities of my solution, it was creating index and FK to my navigation properties. As it is a good improvement I wanted to regenerate all entities. It works well for all my entites except the one which have Navigation properties "AppUserId".

    I see this line added on MyProjectDbContextModelCreatingExtensions, into builder.Entity<MyExistingEntity>

    b.HasOne<AppUser>().WithMany().HasForeignKey(x => x.AppUserId);

    This line was not generate on version 4.21 and the entity generation was working well.

  • 0
    albert created
    Support Team

    guys sorry I missed this one. I already created an issue for this. btw check out these. it's very similar

    • https://support.abp.io/QA/Questions/1280/The-property-'OrganizationUnitExtraProperties'-could-not-be-mapped-because
    • https://support.abp.io/QA/Questions/1271/Add-relation-between-AbpUser-to-My-Table
    • https://github.com/abpframework/abp/issues/8019#issuecomment-796776155
  • 1
    christophe.baille created

    I got a similar issue and got it fixed there:

    https://support.abp.io/QA/Questions/1343

  • 0
    beuko created

    Thank you for answer and link.