Open Closed

Error restoring nuget packages after upgrade to v6.0.0-rc.3 #3597


0
scott7106 created
  • ABP Framework version: v6.0.0-rc.3
  • UI type: Angular
  • DB provider: EF Core
  • Tiered (MVC) or Identity Server Separated (Angular): no
  • Exception message and stack trace:

I upgraded my rc.2 project to rc.3 using the 5.3.4 version of the CLI and the switch-to-preview command. After it updated the package references from rc.2 to rc.3, I am getting the following error trying to run a dotnet restore command on the aspnet-core solution.

This project was created with the Lepton-X theme using the rc.2 version of Suite.

Determining projects to restore... C:\appdev\otised\anlar.everest\aspnet-core\src\Anlar.Everest.HttpApi.Host\Anlar.Everest.HttpApi.Host.csproj : error NU1 102: Unable to find package Volo.Abp.AspNetCore.Mvc.UI.Theme.LeptonX with version (>= 6.0.0-rc.3) [C:\appdev\otised\anl ar.everest\aspnet-core\Anlar.Everest.sln] C:\appdev\otised\anlar.everest\aspnet-core\src\Anlar.Everest.HttpApi.Host\Anlar.Everest.HttpApi.Host.csproj : error NU1 102: - Found 6 version(s) in ABP Commercial NuGet Source [ Nearest version: 1.0.0-rc.3 ] [C:\appdev\otised\anlar.ever est\aspnet-core\Anlar.Everest.sln] C:\appdev\otised\anlar.everest\aspnet-core\src\Anlar.Everest.HttpApi.Host\Anlar.Everest.HttpApi.Host.csproj : error NU1 102: - Found 0 version(s) in Microsoft Visual Studio Offline Packages [C:\appdev\otised\anlar.everest\aspnet-core\Anl ar.Everest.sln] C:\appdev\otised\anlar.everest\aspnet-core\src\Anlar.Everest.HttpApi.Host\Anlar.Everest.HttpApi.Host.csproj : error NU1 102: - Found 0 version(s) in nuget.org [C:\appdev\otised\anlar.everest\aspnet-core\Anlar.Everest.sln] C:\appdev\otised\anlar.everest\aspnet-core\src\Anlar.Everest.HttpApi.Host\Anlar.Everest.HttpApi.Host.csproj : error NU1 102: - Found 0 version(s) in github [C:\appdev\otised\anlar.everest\aspnet-core\Anlar.Everest.sln] C:\appdev\otised\anlar.everest\aspnet-core\src\Anlar.Everest.HttpApi.Host\Anlar.Everest.HttpApi.Host.csproj : error NU1 102: - Found 0 version(s) in OtisEd Private Nuget [C:\appdev\otised\anlar.everest\aspnet-core\Anlar.Everest.sln] C:\appdev\otised\anlar.everest\aspnet-core\src\Anlar.Everest.HttpApi.Host\Anlar.Everest.HttpApi.Host.csproj : error NU1 102: - Found 0 version(s) in ABP Nightly [C:\appdev\otised\anlar.everest\aspnet-core\Anlar.Everest.sln] C:\appdev\otised\anlar.everest\aspnet-core\src\Anlar.Everest.HttpApi.Host\Anlar.Everest.HttpApi.Host.csproj : error NU1 102: - Found 0 version(s) in BlazoriseMyGet [C:\appdev\otised\anlar.everest\aspnet-core\Anlar.Everest.sln] Failed to restore C:\appdev\otised\anlar.everest\aspnet-core\src\Anlar.Everest.HttpApi.Host\Anlar.Everest.HttpApi.Hos t.csproj (in 11.57 sec). 13 of 14 projects are up-to-date for restore.


5 Answer(s)
  • 0
    yekalkan created
    Support Team

    Hi @scott7106,

    Please update CLI to preview version.

    dotnet tool update -g Volo.Abp.Cli --version 6.0.0-rc.3

  • 0
    scott7106 created

    After upgrading the CLI to rc.3, I get this error during the update command for the project.

    [08:29:25 WRN] 1. HTTP request attempt failed to https://api.nuget.org/v3-flatcontainer/volo.abp.aspnetcore.mvc.ui.theme.leptonx/index.json with an error: 404-Not Found. Waiting 2 secs for the next try... [08:29:27 WRN] 2. HTTP request attempt failed to https://api.nuget.org/v3-flatcontainer/volo.abp.aspnetcore.mvc.ui.theme.leptonx/index.json with an error: 404-Not Found. Waiting 4 secs for the next try... [08:29:31 WRN] 3. HTTP request attempt failed to https://api.nuget.org/v3-flatcontainer/volo.abp.aspnetcore.mvc.ui.theme.leptonx/index.json with an error: 404-Not Found. Waiting 7 secs for the next try... [08:29:39 INF] Updating package "Volo.Abp.AspNetCore.Mvc.UI.Theme.LeptonX" from v1.0.0-rc.3 to v1.0.0-rc.4.

    It looks like the fourth attempt was different in some way and worked. But the first 3 attempts for this package failed.

  • 0
    yekalkan created
    Support Team

    It looks like the fourth attempt was different in some way and worked. But the first 3 attempts for this package failed.

    It doesn't do anything different in the 4th attempt. So it is probably a network related issue.

  • 0
    scott7106 created

    I would agree except that I undid all my changes and ran this multiple times and it was the same on all attempts. That does not make sense that a network related issue would occur in the same place on each attempt.

  • 0
    yekalkan created
    Support Team

    Hi again,

    I inspected the code and you are right. It will be fixed in the stable release.