Open Closed

ABP Suite install problem. How can I reinstall? (clean install) #414

User avatar
alper created
Support Team Director

ABP Framework version: v3.1.1 Would you please provide guidance on why I am unable to install ABP Suite v3.1.1. Here are the steps taken:

Step 1: dotnet tool install -g volo.abp.cli (Success)

Step 2: abp login <username> -p <password> (Success)

Step 3: abp suite install (Error below)

Reported here

How to perform an ABP Suite clean install?


4 Answer(s)
  • User Avatar
    alper created
    Support Team Director

    ABP Suite clean install steps:

    1. Remove ABP Suite
      Ensure that ABP Suite is not running! You can also restart your computer to avoid running in a background process.
    abp suite remove

    you can also use:

    dotnet tool uninstall --global Volo.Abp.Suite

    See also

    1. Delete the Suite installation directory:

    for Windows:


    for MAC:


    1. Install ABP Suite
    abp suite install

    you can also use

    dotnet tool install -g Volo.Abp.Suite -add-source***your-api-key-here***/v3/index.json

    don't forget to replace the ***your-api-key*** with yours if you are using the dotnet tool install command. You can find your API key in the NuGet.config of your solution.

  • User Avatar
    0 created

    Tried the above process. Same error. I saw there was a new version of the CLI out, so tried to update that and got the same error. So I tried to remove it all and start from scratch with the same error:

    I'm now not even able to debug the .net core project since remove abp cli.

    [Edit] I was able to get cli reinstalled by specifying the version. But still can't get suite to install.

  • User Avatar
    0 created

    I was able to install suite by specifying the NuGet.Config File in the asp-net folder of the solution. Not sure how it got out of sync. I did this by: dotnet tool install -g Volo.Abp.Suite --configfile "{file path to solution}\aspnet-core\NuGet.Config"

  • User Avatar
    alper created
    Support Team Director

    the problem is you have added "" source to the top of your sources. it's better to keep the official nuget server on top of all other sources.

Made with ❤️ on ABP v8.2.0-preview Updated on March 25, 2024, 15:11