Open Closed

Angular " An error has occurred " on Firefox #75


0
alper created
Support Team

When I browse the Angular application on Firefox I see the below error:

An error has occurred!
Sorry, an error has occured.


4 Answer(s)
  • 0
    alper created
    Support Team

    This is a known issue of Firefox. When you go to https://localhost:44389/api/abp/application-configuration You will see Firefox blocks self-signed SSL certificates as seen below:

    The solution is simple: Click the Advanced button and then Accept the Risk and Continue.

  • 0
    alper created
    Support Team

    How to permit Firefox to trust root authorities

    Firefox has an optional feature that allows the browser to trust root authorities in the Windows certificate store. To activate this feature, you must enable the setting in your browser.

    1. Type about:config into the Firefox address bar.
    2. Press the Accept the Risk and Continue button.
    3. Search for security.enterprise_roots.enabled
    4. In the security.enterprise_roots.enabled window, look to the right side of the screen. If the value is false, double-click on it to set it as true.
    5. Restart Firefox to apply changes.
  • 0
    drpdev2 created

    I faced the exception the same on Chrome. How to fix them?

  • 0
    alper created
    Support Team

    How to connect ASP NET Core self-signed HTTPS development certificate? [Chrome Fix]

    To trust .NET self signed SSL certificates, perform the following one-time step. Close all your browsers and open command prompt, write:

    dotnet dev-certs https --trust
    

    This will allow to trust the self-signed ASP NET Core HTTPS development certificate in your computer. A confirmation prompt will be displayed if the certificate was not previously trusted. Click yes on the prompt to trust the certificate.


    If you want to clear your existing HTTPS certificates. Open command prompt, write:

    dotnet dev-certs https –clean
    

    Google Chrome uses the Certificate Store on Windows for validating certificates, therefore when you run the command, Chrome will not complain about the certificate anymore!

    References:

    • https://www.hanselman.com/blog/DevelopingLocallyWithASPNETCoreUnderHTTPSSSLAndSelfSignedCerts.aspx
    • https://docs.microsoft.com/en-us/aspnet/core/security/enforcing-ssl
    • https://docs.microsoft.com/en-us/xamarin/cross-platform/deploy-test/connect-to-local-web-services#create-a-development-certificate